centos6安装php5.2版本

By | 2014/04/23

1.安装atomic repository
wget -q -O – http://www.atomicorp.com/installers/atomic | sh

2.如果有其他版本的php,先删除
yum remove php*

3.安装php5.2
yum install atomic-php52-php atomic-php52-php-mysql atomic-php52-php-gd atomic-php52-php-xml atomic-php52-php-mbstring

4.安装zend(如果需要的话,估计安装5.2就是为了他吧)
去这里下载相应的zend组件,http://www.zend.com/en/products/guard/downloads-prev
将合适的ZendOptimizer.so文件拷贝到你的php 类库文件中,php.ini 在添加zend_extension=ZendOptimizer.so。
比如:zend_extension=/opt/atomic/atomic-php52/root/usr/lib64/php/modules/ZendOptimizer.so

5.重启httpd验证是否成功。

ps:重启httpd有可能保存,回收到一个No such file or directory的错误提示,只需要根据提示的路径,修改路径或者文件名即可。

发表评论

电子邮件地址不会被公开。

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据